MinGW GCC 4.8.1

configure:4429: gcc -m64  -m64 conftest.c  >&5
conftest.c:1:0: sorry, unimplemented: 64-bit mode not compiled in

Time move forward to next tool. I want GCC 6.1.0

Advertisements
MinGW GCC 4.8.1

Extending S60_5th_Edition_SDK_v1.0 II

gcce.h not emits warnings now.

Whats done:

1) copied content from symcpp

2) removed EXPORT_C from operators

3) post-operators __NO_THROW in c++11 changed to noexcept:

#if __cplusplus == 199711L || __GNUC__ < 3 // last for rss preprocessor
#define __NO_THROW throw ()
#define __THROW(t) throw (t)
#elif  __cplusplus == 201103L ||  __cplusplus == 201402L
#define __NO_THROW noexcept
// #define __THROW(t) // not needed for new/delete operators in C++11/14
#else
#error “Unknown c++ standart! Please add fix gcce.h at line 85”
#endif

4) get rid from stupid warnings:

‘void* operator new(unsigned int, unsigned int)’ is a usual (non-placement) deallocation function in C++14:

#if __GNUC__ > 4
/*get rid from endless warnings
because from C++14 :
The placement form void* operator new(size_t, size_t)
is not allowed because the matching signature of the
deallocation function, void operator delete(void*, size_t),
is a usual (not placement) deallocation function.*/
#pragma GCC diagnostic push
#pragma GCC diagnostic ignored “-Wc++14-compat”
#endif

Extending S60_5th_Edition_SDK_v1.0 II

Extending S60_5th_Edition_SDK_v1.0

What done:
ld v2.25.1 incorrectly recognized order params in generated makefile, but this order is normal for ld (Symbian ADT Sourcery G++ Lite 4.4-172) 2.19.51.20090709.

SYMBIAN_UREL_LINK_FLAGS contain linker option “–Tdata 0xAA00000”.

This command: “\t\$(LD) “,”\$(STATIC_LIBS) “,”\$(SYMBIAN_UDEB_LINK_FLAGS) “, “\$(SHARED_OBJECT_OPTION) “,  “\$(CODE_SEGMENT_START) “, “\$(DATA_SEGMENT_START) 0x400000 ” treats binutils 2.25.1 like ld –Tdata 0x400000 and value SYMBIAN_UREL_LINK_FLAGS ignored.

This is fix for cl_bpabi.pm:

if ($Bld =~ /DEB/)
{
&main::Output(
“\t\$(LD) “,”\$(STATIC_LIBS) “,”\$(SYMBIAN_UDEB_LINK_FLAGS) “, “\$(SHARED_OBJECT_OPTION) “,
“\$(CODE_SEGMENT_START) “, “\$(DATA_SEGMENT_START) 0x400000 “, “\$(SYMVER_OPTION) “,”\$(SO_NAME_OPTION) “,
“$LinkAs”,”\$(SYMBIAN_UDEB_LINK_FLAGS) ”
);
}
else
{
&main::Output(
“\t\$(LD) “,”\$(STATIC_LIBS) “,”\$(SYMBIAN_UREL_LINK_FLAGS) “,”\$(SHARED_OBJECT_OPTION) “,
“\$(CODE_SEGMENT_START) “, “\$(DATA_SEGMENT_START) 0x400000 “, “\$(SYMVER_OPTION) “,”\$(SO_NAME_OPTION) “,
“$LinkAs”,”\$(SYMBIAN_UREL_LINK_FLAGS) ”
);
}

 

Failed add declaration for operators new and delete conforming C++11/14 in gcce.h… Working from start but not now…

 

Extending S60_5th_Edition_SDK_v1.0

GCC 5.2 works!

Problem source is linker options placed in wrong order in sdk script bpabi.pm

Variables contains custom commands from mmp’s comes first, second – builtins and – whoala – nothing work! Appending custom variables is solution. Why this work with gcce 4.4.1?

Stil can’t built scummvm with lto…

My email permanently banned on gcc-help mail lists..

Neverhood runs not wery smoothly T_T

GCC 5.2 works!